Impresiones del SSD OCZ Vertex 2

Estas navidades decidí darme un capricho a modo de auto-regalo… algo que llevaba rondando mi mente varios meses ya. En efecto, se trataba de un SSD (Solid-State Drive). Una vez decidido a comprarlo empecé a buscar y a comparar en tiendas online, pero andaba un poco perdido en cuanto a las novedades, así que busqué en Xataka. En uno de los artículos, leí un comentario que me llamó la atención y que decía: […] SSD Vertex 2 (el mejor del mercado hoy por hoy 100% recomendable) de 120 GB […], así que me puse a buscar más información acerca de él.

Tenía muy buenas características, un precio elevado pero no astronómico y era uno de los más solicitados en las tiendas (por algo sería…), así que me puse a leer algún que otro análisis (los buenos suelen estar en inglés…) y finalmente me decidí por él, concretamente por uno de 120 GB.

DSC02245

La idea de estos discos es para almacenar el sistema operativo, programas y los archivos más usados, no para almacenamiento masivo como fotos o películas. Calculé cuánto me podía ocupar todo eso y el de 120 GB era el que más me convenía: más no porque el precio empezaba a dispararse y ya no resultaba tan atractivo, y menos tampoco, porque no me quería quedar corto o muy justo.

Lo iba a comprar en Alternate, pero entonces me acordé de que tenía un cupón de 30 € para Amazon.de y qué mejor ocasión que ésta para utilizarlo (nada de preocuparse por si viene en alemán). Actualmente su precio ronda los 200 €, así que se me quedó en 166 € envío incluido, así que nada mal. Lo malo es que al venir de Alemania me tardaría más que comprándolo en una tienda online española, pero el cupón descuento fue decisivo. Además, Amazon es una (sino la que más) de las mejores tiendas online.

DSC02246DSC02247

La verdad, todo apuntaba a que sería un excelente SSD. Y no me equivoqué. Pero hasta que llegué a disfrutarlo como debía pasaron varios días… y muchos dolores de cabeza. Me pasaron todo tipo de cosas. Todo empezó cuando me dispuse a instalar Windows 7 en el recién estrenado SSD:

DSC02251

Nunca me olvidaré de ti

Ese puñetero mensaje (por no decir otra cosa) fue el culpable de que todo empezase mal: no podía instalar Windows 7 en el SSD, de ninguna manera. Siempre salía ese mensaje después del primer reinicio (más concretamente cuando estaba iniciando servicios), y cuando reiniciaba, salía otro mensaje diciendo que la instalación no se había completado bien y que tendría que volver a empezar (o algo así).

Intenté instalar Windows de todas las maneras posibles; no sé cuantas veces lo haría probando diferentes cosas, que si instalar sólo con los componentes esenciales del ordenador, que si instalando desde un pendrive por si era cosa del lector de DVD, que si otra imagen de Windows por si la mía estuviera dañada… Nada, todas y cada una de las intentonas fueron fallidas.

Entonces pensé que tal vez el SSD estuviera defectuoso, así que para descartar esta opción instalé Ubuntu 10.10 en él. Funcionó a la primera, así que no era cosa del SSD. Al comprarlo de 2,5 pulgadas lo podría usar también en un ordenador portátil, así que se me ocurrió meterlo en el mío y ver si desde allí podía instalar Windows 7.

DSC02249

El SSD de 2,5 pulgadas viene con un adaptador para bahías de 3,5 pulgadas, pero no incluye el cable de datos SATA

Eso lo probé nada más probar a instalar Ubuntu en el de sobremesa, así que cuando arranqué el portátil con el SSD me quedé boquiabierto, literalmente. ¿Por qué? pues porque Ubuntu arrancó como un auténtico rayo. Desde que pulsé el botón de encendido hasta que vi el escritorio, no pasarían más de 10 segundos… No lo cronometré, pero probablemente fue el arranque más rápido de un sistema operativo que hubiera visto hasta la fecha, teniendo en cuenta que en esos pocos segundos también estaba incluida la carga de la BIOS.

Además, aquello me llamó doblemente la atención, porque la instalación fue hecha en el ordenador de sobremesa, y el portátil tenía un hardware totalmente diferente. Pero arrancó, instaló lo nuevo que detectó (el Bluetooth, el Wi-Fi, etc.), ¡y aquí como si no hubiera pasado nada! Así que un aplauso para la comunidad, de verdad.

La emoción duró poco porque enseguida formateé de nuevo para ver si conseguía instalar Windows en él… y esta vez lo conseguí a la primera. Así que todo apuntaba a que había algo en mi ordenador de sobremesa que daba algún tipo de problema con la instalación de Windows 7 en un SSD. Por supuesto, en este caso, el pasar de un Windows instalado en el portátil a intentar arrancarlo desde el sobremesa fue inútil porque daba una BSOD.

Al final se me ocurrió instalar Windows 7 en un disco duro normal y luego clonarlo al SSD, aunque me resultaba una pequeña chapuza, la verdad. Pero ya no me quedaban más opciones, lo había probado ya todo y en Internet no encontré ayuda con ese dichoso error (si al menos hubiera aparecido en inglés…).

DSC02250

Si estás pensando en que cuánto polvo hay, te diré que eso no es nada

Llegado a este punto me encontraba en mi 2ª fase de problemas relacionados con el SSD… La idea de la clonación al final dio resultado, pero hasta que me salió bien también sufrí de unos cuentos formateos / instalaciones. Nunca había clonado un disco duro, así que tuve que investigar el software que existía y primero me decanté por el Clonezilla. Parecía que iba bien la cosa pero luego no conseguía arrancar desde el SSD.

Yo no sé que pasó, pero llegué a un punto en el cual ni siquiera la BIOS (ni la del sobremesa ni la del portátil) me reconocía el SSD, era como si estuviera muerto. Ya me estaba poniendo nervioso de verdad y pensando en si Amazon me devolvería el dinero… Luego, mágicamente, volvió a la vida y pude volver a hacer más pruebas. Cosas de la informática.

Probé otro software clonador de discos, esta vez el Acronis True Image Home 2011, y éste fue el bueno. Tal vez el Clonezilla no lo manejé bien, pero el caso es que el Acronis fue el salvador. Cuando por fin vi la pantalla de Windows 7 iniciándose sentí una gran satisfacción por haberlo conseguido y poder disfrutar de mi compra de una vez por todas.

Pero todavía me quedaba pasar por mi 3ª (y última) fase de problemas. Resulta que el rendimiento del SSD no era el esperado. Por supuesto, notaba muchísima diferencia respecto a un disco duro tradicional, pero hice un test con el ATTO Disk Benchmark y no me dio unos datos acordes a las características del SSD. Me faltaba hacerlo funcionar bajo AHCI. Esta característica ha de ser soportada por el hardware y estar disponible en la BIOS, pero aparentemente cumplía lo primero pero no lo segundo.

Me metí en la BIOS y bajo “SATA mode” sólo me salían las opciones de ATA y RAID, siendo ATA la seleccionada. Y claro, RAID no era lo que yo quería, sino AHCI. Al no estar disponible en esas opciones ni en ninguna otra parte de la BIOS busqué por Internet y había mucha gente que preguntaba lo mismo que yo y pedía a Dell una actualización de la BIOS… actualización que por supuesto nunca llegaría. Indignado con Dell, ya me estaba viendo modificando la NVRAM como hice con mi portátil para habilitar la virtualización, pero en este caso no parecía tan sencillo y aunque alguien lo planteó, no se llevó a cabo.

Ya casi me di por vencido, pero finalmente decidí probar a poner la opción RAID, porque en los foros de Dell había quien decía que esa opción era AHCI realmente, pero otros decían que así no conseguían nada. Como no me quería quedar con la duda, hice un backup de mis datos por si acaso y lo probé. Y como estaba previsto, recibí una BSOD nada más intentar arrancar Windows, pero eso ya había leído que se solucionaba cambiando un valor del registro.

Pero no lo conseguía tampoco de esa manera, y probé otros métodos “más extraños” y enrevesados que tampoco me funcionaron. Lo malo es que cada vez que me fallaba el arranque tenía que reiniciar, entrar a la BIOS, volver a cambiar a ATA, otro reinicio, volver a Windows, probar otra cosa, reiniciar, volver a poner RAID en la BIOS y reintentar arrancar Windows. Casi nada.

Al final, después de leer inútilmente muchas cosas acerca de cómo activar AHCI con Windows ya instalado, esta página fue la salvadora en esta ocasión. Desde el principio estaba haciendo lo correcto, pero sólo cambiaba un registro de los dos que había que cambiar. Tan fácil como eso.

Una vez arranqué satisfactoriamente en modo AHCI, sólo me quedaba instalar los controladores de Intel (que mejoran el rendimiento respecto a los que vienen de serie con Windows 7). Y entonces, sólo entonces, me sentí satisfecho con la compra. Algo que parecía un juego de niños me costó bastante más de lo previsto, pero finalmente lo logré.

ATTO Disk Benchmark (HDD)ATTO Disk Benchmark (SSD)

ATTO Disk Benchmark comparando el disco duro de serie (izquierda) con el nuevo SSD (derecha)

El disco duro que me venía de serie en el ordenador era (y sigue siendo) bastante bueno, un Western Digital Caviar Blue de 640 GB, pero claro, comparándolo ahora con el OCZ Vertex 2, se queda muy atrás. El SSD casi casi triplica la tasa de lectura, pasando de unos 94 MB/s a unos asombros 280 MB/s, prácticamente lo que anuncia el fabricante. En escritura tampoco se queda corto y alcanza casi los 270 MB/s también una increíble cifra. También hay que tener en cuenta que el test del SSD lo hice teniéndolo como unidad del sistema, al contrario que el disco duro tradicional, que estaba conectado como una unidad independiente.

También probé a ejecutar de nuevo la Evaluación de la experiencia en Windows (WEI para los amigos) y ahora el disco ha dejado de ser el gran cuello de botella en el ordenador. No recuerdo el valor exacto, pero antes rondaba los 5 coma algo.

Windows Experience Index

Ahora hacer cualquier cosa relacionada con operaciones de lectura / escritura en disco es mucho, mucho más rápido. Donde más lo noto es en la apertura de programas; es algo que da gusto verlo. Es prácticamente como si ya los tuvieras cargados en RAM desde un principio. También se nota un montón al instalar programas (no desde dispositivos ópticos, claro), al buscar archivos (es instantáneo) y en la suspensión / reanudación / hibernación de Windows.

Donde sí que me esperaba un poco más de diferencia es en el arranque del sistema: aproximadamente tarda unos 20 segundos desde que aparece la pantalla de “Iniciando Windows” hasta ver el escritorio. Claro que ahora, nada más verlo, ya puedes ir lanzando aplicaciones.

Otro vídeo mostrando de lo que es capaz el OCZ Vertex 2

El precio de los SSD sigue siendo bastante caro, pero cuando sean un poco más asequibles, tipo 1 GB = 1 € (apuesto a que este año lo veremos), será un elemento muy a tener en cuenta para mejorar tu ordenador por relativamente poco dinero. La diferencia se nota, y mucho.

31 comentarios / Añade el tuyo debajo

  1. Hola. El caso es que me he leido todo el post por intentar saber si hay mucha diferencia entre el modo IDE y AHCI. Dices que no estabas satisfecho con los resultados en IDE y que cuando los cambias a AHCI aumenta el rendimidiento. Podrias decir cual era el rendimiento sin AHCI y con AHCI.
    Gracias

    1. Hola Fran,

      Tienes razón, no lo aclaro en datos comparables. Lo que comparo con las dos capturas del ATTO Disk Benchmark es entre un disco duro tradicional y el SSD ya sobre AHCI. Ya hace bastante tiempo de esto y la verdad no me acuerdo de cómo de grande era la diferencia entre el SSD funcionando bajo AHCI o sin él, pero lo que sí que me acuerdo es que sin él no llegaba a los datos publicitados por el SSD.

      Un saludo.

  2. Carlos, excelente articulo. Lo acabo de ver y aunque lo hayas publicado hace casi un año, creo que sigue siendo totalmente vigente. No he dejado de aprender según iba leyéndolo. Muchísimas gracias.
    Tengo un pollo con un SSD que tiene el S.O. de mucho cuidado y estoy tratando de conocer para poder diagnosticar.
    Repito, excelente aporte y muchas gracias

    1. Muchas gracias a ti, Rafael, por molestarte en agradecérmelo :D

      Un saludo!!

  3. Buenas,

    creo que ha sido el único blog donde se habla de lo mismo que me pasa a mí… no has descubierto la forma de instalarlo sobre le SSD directamente sin necesidad de clonar el disco duro?

    Yo ya he probado de todo como tú, instalar desde un pendrive, diferentes versiones de windows, instalarlo como RAID, AHCI, IDE, actualización de BIOS, etc.

    Siempre me pasa lo mismo que a ti, cuando reinicia por primera vez y pone “Iniciando servicios” se apaga el PC, lo enciendo y ya pone que la instalación ha sufrido un error, que pulse Aceptar y se reiniciará para continuar la instalación… y ya entra en un bucle infinito…

    Mañana si tengo tiempo, probaré exactamente lo que me cuentas de clonar el disco duro, aunque si que es un chapuza padre :PPP

    Saludos y gracias por la ayuda!, a ver si a mi me sale como a ti ;D

    1. Hola!

      Vaya, ya pensé que iba a ser el único bicho raro al que le pasaba esto! Muchas veces, buscando por Internet, se suele encontrar a gente que le pasa exactamente el mismo problema que a ti jaja

      La verdad es que es aún un misterio… no he descubierto el porqué de este problema. Ni siquiera tengo claro de quién es el problema, si de Windows 7, si del SSD, del hardware de mi ordenador o una combinación de los tres :P (tu ordenador no será un Dell, ¿verdad?)

      Ya me cuentas qué tal te ha ido y si finalmente has podido instalar Windows, aunque sea con esa chapuza jaja

      Un saludo ;)

  4. hola lei tu post y te cuento que me paso exactamente lo mismo, “identico”, despues de horas logre resolverlo te cuento los pasos posteriores a todo lo que vos hiciste, como no queria clonar ya que estaba encrapichado a instalarlo de 0 me pase dos dias completos haciendo pruebas y revisando 1000 foros a ver si encontraba una solucion, como no la encontre te paso a comentar lo que hice,
    -actualize la bios de mi pc con clear cmos posterior
    -deje toda la config como estaba en native ide nada de ahci ni nada y todo lo demas como quedo la bios de fabrica digamos
    -el disco solido me lo reconocio bien apague el equipo y lo desconecte.
    -instale en un disco comun windows seven de 64
    -instale el Acronis_Disk_Director apague el pc y enchufe el ssd como esclavo entre comillas, configure en la bios que arranque el disco comun
    -arranco windows me reconocio el ssd y con el acronis le hice un wipe y una particion nueva cuando termino reinicie desconecte el disco comun y empece a instalar el windows en el ssd, cuando llegue a la pantallas de particiones elimine la particion que habia creado el acronis y cree una nueva restandole 4 megas (con las flechita de al lado toque cuatro vecespara abajo) y di siguiente (supuestamente para que cree el mbr nuevo en esos cuatro megas) y asi sin hacer nada mas sorpresivamente instalo todo el windows volando y lo estoy usando hace unos dias sin ningun problema hasta ahora la pc vuela como nunca estoy sorprendido del funcionamiento que tiene realmente, estos dias hice varias optimizaciones que andan dando vueltas por internet y el rendimiento es optimo, sin mas espero les ayude en algo

    1. Hola Ángel,

      Hace relativamente poco tuve que formatear y antes de volver a hacer la pequeña chapuza que cuento en el post, probé tu método pero no tuve suerte. De todas formas, muchas gracias por tu comentario, puede que le sirva a alguien.

      Un saludo.

  5. te cuento que un amigo compro el mismo disco y tuvimos nuevamente el mismo problema que comentamos segui los pasos exactamente igual que como los describi antes y funciono nuevamente, puede que te hayas salteado algun paso porque te aseguro que andubo dos veces no obvie ningun paso

    1. Hola,

      Creo que no me funcionó tu método porque no utilicé el Acronis Disk Director, porque no lo tenía, y utilicé otro programa similar.
      Para la próxima vez intentaré usar el Acronis.

      Gracias de nuevo! :)

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados con *